opus-tools: disable flac when it is not selected
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 10 Sep 2013 18:07:45 +0000 (15:07 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 10 Sep 2013 19:49:25 +0000 (21:49 +0200)
opus-tools expects flac since the 0.1.7 bump unless otherwise told so.
Disable it when it's not selected. Fixes:
http://autobuild.buildroot.net/results/c8c/c8c1a682336c150ee401f76b173944611b96bd4e/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/opus-tools/opus-tools.mk

index bb11a19239049fcfc683c6b4a695caa30561781b..f4dee745fef9f0363466b0d7b2732f7b6c580639 100644 (file)
@@ -19,4 +19,10 @@ else
 OPUS_TOOLS_CONF_OPT += --disable-sse
 endif
 
+ifeq ($(BR2_PACKAGE_FLAC),y)
+OPUS_TOOLS_DEPENDENCIES += flac
+else
+OPUS_TOOLS_CONF_OPT += --without-flac
+endif
+
 $(eval $(autotools-package))