package/syslog-ng: fix localstatdir directory
authorAdam Duskett <Aduskett@gmail.com>
Tue, 12 Jul 2016 17:09:20 +0000 (13:09 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 12 Jul 2016 21:50:33 +0000 (23:50 +0200)
syslog-ng is built with the default buildroot flag localstatdir=/var

This causes three issues:

1) syslog-ng creates two files (syslog-ng.ctl and syslog-ng.persist in /var)
which shouldn't have random files generated in it.

2) SELinux expects it in it's default directory /var/run.

3) This breakes read only file systems because /var/ usually isn't mounted as
a seperate filing system.

Setting the buildflag to the default /var/run
fixes all three of thee of these issues.

Signed-off-by: Adam Duskett <aduskett@codeblue.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/syslog-ng/syslog-ng.mk

index 1acaad8dea85cd85ec946b33f3ae32b620844d0b..c11d3bde4933e94a00ab2d300ae7b32a0a0d0df7 100644 (file)
@@ -13,7 +13,7 @@ SYSLOG_NG_DEPENDENCIES = host-bison host-flex host-pkgconf \
        eventlog libglib2 openssl pcre
 # rabbit-mq needs -lrt
 SYSLOG_NG_CONF_ENV = LIBS=-lrt
-SYSLOG_NG_CONF_OPTS = --disable-manpages
+SYSLOG_NG_CONF_OPTS = --disable-manpages --localstatedir=/var/run
 
 # We override busybox's S01logging init script
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)