mtd: add mtdpart option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 4 Aug 2015 11:19:38 +0000 (08:19 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 28 Aug 2015 17:47:54 +0000 (19:47 +0200)
As pointed by Jörg Krause one of the novelties of the 1.5.2 release is
the new mtdpart tool, so add an option for it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mtd/Config.in
package/mtd/mtd.mk

index 6653464f16cc7520ba8750af622dd13fe8c96624..6e4346f2988e87585f5be978922043794282405d 100644 (file)
@@ -71,6 +71,9 @@ config BR2_PACKAGE_MTD_MTD_DEBUG
        bool "mtd_debug"
        default y
 
+config BR2_PACKAGE_MTD_MTDPART
+       bool "mtdpart"
+
 config BR2_PACKAGE_MTD_NANDDUMP
        bool "nanddump"
        default y
index 42a8c1deb34b74d8f167f9ed271ee13d6de842c1..0fb9fc2c1acc9d8154af278aa52e392b58544441 100644 (file)
@@ -63,6 +63,7 @@ MTD_TARGETS_$(BR2_PACKAGE_MTD_FTL_FORMAT)     += ftl_format
 MTD_TARGETS_$(BR2_PACKAGE_MTD_JFFS2DUMP)       += jffs2dump
 MTD_TARGETS_$(BR2_PACKAGE_MTD_MKFSJFFS2)       += mkfs.jffs2
 MTD_TARGETS_$(BR2_PACKAGE_MTD_MTD_DEBUG)       += mtd_debug
+MTD_TARGETS_$(BR2_PACKAGE_MTD_MTDPART)         += mtdpart
 MTD_TARGETS_$(BR2_PACKAGE_MTD_NANDDUMP)                += nanddump
 MTD_TARGETS_$(BR2_PACKAGE_MTD_NANDTEST)                += nandtest
 MTD_TARGETS_$(BR2_PACKAGE_MTD_NANDWRITE)       += nandwrite