gst1-plugins-good: add optional dependency on jack2
authorBrad Love <brad@nextdimension.cc>
Thu, 23 Aug 2018 20:18:05 +0000 (15:18 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 Aug 2018 21:23:45 +0000 (23:23 +0200)
Jack2 audio server is part of buildroot, but the jack gst plugins are
disabled completely in gst1-plugins-good, whether or not jack2 is
selected. This changes the logic so that if the build system
determines that the jack2 audio server is selected, then the jack
plugins are enabled. If the plugins are enabled, then jack2 is also
added as a dependency to gst1-plugins-good.

Signed-off-by: Brad Love <brad@nextdimension.cc>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk

index c1ed039bc76d983c275ec7d511531de6cfcbeecb..21a7668c65d650e14c171908b0be9e659bb462d5 100644 (file)
@@ -25,13 +25,19 @@ GST1_PLUGINS_GOOD_CONF_OPTS = \
 
 # Options which require currently unpackaged libraries
 GST1_PLUGINS_GOOD_CONF_OPTS += \
-       --disable-jack \
        --disable-libdv \
        --disable-dv1394 \
        --disable-shout2
 
 GST1_PLUGINS_GOOD_DEPENDENCIES = gstreamer1 gst1-plugins-base
 
+ifeq ($(BR2_PACKAGE_JACK2),y)
+GST1_PLUGINS_GOOD_CONF_OPTS += --enable-jack
+GST1_PLUGINS_GOOD_DEPENDENCIES += jack2
+else
+GST1_PLUGINS_GOOD_CONF_OPTS += --disable-jack
+endif
+
 ifeq ($(BR2_PACKAGE_LIBV4L),y)
 GST1_PLUGINS_GOOD_CONF_OPTS += --with-libv4l2
 GST1_PLUGINS_GOOD_DEPENDENCIES += libv4l