tunctl: new package
authorSergio Prado <sergio.prado@e-labworks.com>
Sat, 23 Jul 2016 14:18:50 +0000 (11:18 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Jul 2016 20:56:24 +0000 (22:56 +0200)
Tunctl is a tool for controlling the TUN/TAP driver in Linux.

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
[Thomas: use $(TARGET_CONFIGURE_OPTS).]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/tunctl/Config.in [new file with mode: 0644]
package/tunctl/tunctl.hash [new file with mode: 0644]
package/tunctl/tunctl.mk [new file with mode: 0644]

index 6b5b011a817c879b08bf190e00ee6f4bb721e0f8..46ad2768f44e5eee9c049f721521273933f4bbdb 100644 (file)
@@ -1575,6 +1575,7 @@ endif
        source "package/tn5250/Config.in"
        source "package/tor/Config.in"
        source "package/transmission/Config.in"
+       source "package/tunctl/Config.in"
        source "package/tvheadend/Config.in"
        source "package/udpcast/Config.in"
        source "package/ulogd/Config.in"
diff --git a/package/tunctl/Config.in b/package/tunctl/Config.in
new file mode 100644 (file)
index 0000000..26eed4c
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_TUNCTL
+       bool "tunctl"
+       help
+         Tunctl is a tool for controlling the TUN/TAP driver in Linux.
+
+         https://sourceforge.net/projects/tunctl/
diff --git a/package/tunctl/tunctl.hash b/package/tunctl/tunctl.hash
new file mode 100644 (file)
index 0000000..d3aaeec
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 aa2a6c4cc6bfacb11e0d9f62334a6638a0d435475c61230116f00b6af8b14fff  tunctl-1.5.tar.gz
diff --git a/package/tunctl/tunctl.mk b/package/tunctl/tunctl.mk
new file mode 100644 (file)
index 0000000..81e6c8c
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# tunctl
+#
+################################################################################
+
+TUNCTL_VERSION = 1.5
+TUNCTL_SOURCE = tunctl-$(TUNCTL_VERSION).tar.gz
+TUNCTL_SITE = http://downloads.sourceforge.net/project/tunctl/tunctl/$(TUNCTL_VERSION)
+
+TUNCTL_LICENSE = GPLv2
+TUNCTL_LICENSE_FILES = tunctl.c
+
+define TUNCTL_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) tunctl
+endef
+
+define TUNCTL_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/tunctl $(TARGET_DIR)/usr/sbin/tunctl
+endef
+
+$(eval $(generic-package))