package/python-scapy3k: remove package
authorGabriel Potter <gabriel@potter.fr>
Tue, 3 Dec 2019 23:28:32 +0000 (23:28 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Dec 2019 21:17:29 +0000 (22:17 +0100)
Scapy3k is deprecated since Scapy supports Python 3. Scapy should be
used instead.

See https://bugs.busybox.net/show_bug.cgi?id=12376

Signed-off-by: Gabriel Potter <gabriel@potter.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/Config.in
package/python-scapy3k/Config.in [deleted file]
package/python-scapy3k/python-scapy3k.hash [deleted file]
package/python-scapy3k/python-scapy3k.mk [deleted file]

index 02886bff362dcae897aa7220b066fdc5dbbdbdd9..8436951f0f643e36a91ee85bd492d0dfcd9151de 100644 (file)
@@ -146,6 +146,15 @@ endif
 
 comment "Legacy options removed in 2020.02"
 
+config BR2_PACKAGE_PYTHON_SCAPY3K
+       bool "python-scapy3k is replaced by python-scapy"
+       select BR2_LEGACY
+       select BR2_PACKAGE_PYTHON_SCAPY
+       help
+         python-scapy3k has been deprecated, since python-scapy has
+         gained Python 3 support. Use BR2_PACKAGE_PYTHON_SCAPY
+         instead.
+
 config BR2_BINUTILS_VERSION_2_30_X
        bool "binutils version 2.30 support removed"
        select BR2_LEGACY
index 9e2b78fe6a5a687a5f2e2ca844233d538f22c812..307583d01f61f4a6245865c916c28665bcb81b1d 100644 (file)
@@ -1078,7 +1078,6 @@ menu "External python modules"
        source "package/python-rtslib-fb/Config.in"
        source "package/python-scandir/Config.in"
        source "package/python-scapy/Config.in"
-       source "package/python-scapy3k/Config.in"
        source "package/python-schedule/Config.in"
        source "package/python-sdnotify/Config.in"
        source "package/python-secretstorage/Config.in"
diff --git a/package/python-scapy3k/Config.in b/package/python-scapy3k/Config.in
deleted file mode 100644 (file)
index 3e75fcd..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_PYTHON_SCAPY3K
-       bool "python-scapy3k"
-       depends on BR2_PACKAGE_PYTHON3
-       select BR2_PACKAGE_PYTHON3_ZLIB
-       help
-         Network packet and pcap file crafting/sniffing/manipulation
-         security tool (based on scapy) with python3 compatibility.
-
-         https://github.com/phaethon/scapy
diff --git a/package/python-scapy3k/python-scapy3k.hash b/package/python-scapy3k/python-scapy3k.hash
deleted file mode 100644 (file)
index 0faa376..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally computed:
-sha256  3717913cb54f211918eccb65fad9ccf8a66bd542a4a659b2c0ac762db08eb766  python-scapy3k-0.18.tar.gz
diff --git a/package/python-scapy3k/python-scapy3k.mk b/package/python-scapy3k/python-scapy3k.mk
deleted file mode 100644 (file)
index 63f081e..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-################################################################################
-#
-# python-scapy3k
-#
-################################################################################
-
-PYTHON_SCAPY3K_VERSION = 0.18
-PYTHON_SCAPY3K_SITE = $(call github,phaethon,scapy,v$(PYTHON_SCAPY3K_VERSION))
-PYTHON_SCAPY3K_SETUP_TYPE = distutils
-PYTHON_SCAPY3K_LICENSE = GPL-2.0+
-
-$(eval $(python-package))