libnice: add gstreamer support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 6 May 2018 09:42:29 +0000 (11:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 28 May 2018 20:55:58 +0000 (22:55 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libnice/libnice.mk

index e023728f44836cf43c9066937512df086119c169..49c29f9a60a69c25eb1939081af96b6dc146c507 100644 (file)
@@ -10,8 +10,19 @@ LIBNICE_LICENSE = MPL-1.1 or LGPL-2.1
 LIBNICE_LICENSE_FILES = COPYING COPYING.MPL COPYING.LGPL
 LIBNICE_DEPENDENCIES = gnutls libglib2 host-pkgconf
 LIBNICE_INSTALL_STAGING = YES
-LIBNICE_CONF_OPTS = \
-       --without-gstreamer \
-       --without-gstreamer-0.10
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
+LIBNICE_CONF_OPTS += --with-gstreamer-0.10
+LIBNICE_DEPENDENCIES += gst-plugins-base
+else
+LIBNICE_CONF_OPTS += --without-gstreamer-0.10
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
+LIBNICE_CONF_OPTS += --with-gstreamer
+LIBNICE_DEPENDENCIES += gst1-plugins-base
+else
+LIBNICE_CONF_OPTS += --without-gstreamer
+endif
 
 $(eval $(autotools-package))