auto remove empty /usr/share dir
authorMike Frysinger <vapier@gentoo.org>
Thu, 18 Nov 2010 21:25:58 +0000 (16:25 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 24 Nov 2010 21:14:33 +0000 (22:14 +0100)
Often times, the only reason /usr/share exists is because of documentation
installed into it.  So once we're done cleaning the docs, attempt to rmdir
/usr/share.  If it's empty, things will work out nicely.

[Peter: use make infrastructure to ignore errors rather than shell]
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index a53ef89da715f82320344f05d470e7aedd9ff2d0..86aea91a25b4b42091029180877ba067426e6228 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -416,6 +416,7 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
        rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
        rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
        rm -rf $(TARGET_DIR)/usr/share/gtk-doc
+       -rmdir $(TARGET_DIR)/usr/share 2>/dev/null
 endif
        find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
        find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \