package/dmalloc: fix static build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 15 May 2021 15:17:30 +0000 (17:17 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 15 May 2021 16:09:29 +0000 (18:09 +0200)
Build of dmalloc is broken since commit
19ec872f169a851b48ba04d22432b7c0939847d4 because --enable-shlib is
unconditionally set

Fixes:
 - http://autobuild.buildroot.org/results/62c9c6aebca60649bd6f635125507bf10d63fc05

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/dmalloc/dmalloc.mk

index 638fe0fcda7d9e83ad035188085fb818ec4b6ff2..749c35359c16461ba4820e4eab711b9b1c3f8d20 100644 (file)
@@ -13,10 +13,12 @@ DMALLOC_LICENSE = MIT-like
 DMALLOC_LICENSE_FILES = dmalloc.h.1
 
 DMALLOC_INSTALL_STAGING = YES
-DMALLOC_CONF_OPTS = --enable-shlib
 DMALLOC_CFLAGS = $(TARGET_CFLAGS)
 
-ifeq ($(BR2_STATIC_LIBS),)
+ifeq ($(BR2_STATIC_LIBS),y)
+DMALLOC_CONF_OPTS += --disable-shlib
+else
+DMALLOC_CONF_OPTS += --enable-shlib
 DMALLOC_CFLAGS += -fPIC
 endif