libglib2: halt build early with description if host glib-genmarshal isn't found
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jan 2009 18:17:57 +0000 (18:17 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jan 2009 18:17:57 +0000 (18:17 -0000)
package/libglib2/libglib2.mk

index db4d92e4fdbaa05b726d2ad72ed72b2626bfa924..2cf2459dcfaa17ed7efb22c414269036a9cdf168 100644 (file)
@@ -62,3 +62,10 @@ LIBGLIB2_DEPENDENCIES+=libiconv
 endif
 
 $(eval $(call AUTOTARGETS,package,libglib2))
+
+# we NEED a host glib-genmarshal
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+ifeq ($(wildcard $(HOST_GLIB)/bin/glib-genmarshal),)
+$(error Host glib-genmarshal not found. Please install glib development package on your host (something like libglib2.0-dev))
+endif
+endif