package/libpcap: bump to version 1.9.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 3 Feb 2019 16:17:40 +0000 (17:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Feb 2019 10:30:02 +0000 (11:30 +0100)
- Disable Endace DAG card support as libdag is not available in
  buildroot
- Add upstream patch to fix build on musl

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Titouan Christophe <titouan.christophe@railnova.eu>
Tested-by: Yann E . MORIN <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libpcap/0001-pcap-usb-linux.c-add-missing-limits.h-for-musl-systems.patch [new file with mode: 0644]
package/libpcap/libpcap.hash
package/libpcap/libpcap.mk

diff --git a/package/libpcap/0001-pcap-usb-linux.c-add-missing-limits.h-for-musl-systems.patch b/package/libpcap/0001-pcap-usb-linux.c-add-missing-limits.h-for-musl-systems.patch
new file mode 100644 (file)
index 0000000..aabaef3
--- /dev/null
@@ -0,0 +1,26 @@
+From aafa3512b7b742f5e66a5543e41974cc5e7eebfa Mon Sep 17 00:00:00 2001
+From: maxice8 <thinkabit.ukim@gmail.com>
+Date: Sun, 22 Jul 2018 18:54:17 -0300
+Subject: [PATCH] pcap-usb-linux.c: add missing limits.h for musl systems.
+
+fix compilation on musl libc systems like Void Linux and Alpine.
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Retrieved from:
+https://github.com/the-tcpdump-group/libpcap/commit/aafa3512b7b742f5e66a5543e41974cc5e7eebfa]
+---
+ pcap-usb-linux.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pcap-usb-linux.c b/pcap-usb-linux.c
+index 6f8adf65e..b92c05ea1 100644
+--- a/pcap-usb-linux.c
++++ b/pcap-usb-linux.c
+@@ -50,6 +50,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <limits.h>
+ #include <string.h>
+ #include <dirent.h>
+ #include <byteswap.h>
index f8bc1bcfef1ab6bf476b1d26cbb849a8d6ff0fc9..19ce2adbe18c09783d88227a47d9e1712f77ca0f 100644 (file)
@@ -1,5 +1,5 @@
 # Locally calculated after checking pgp signature
-sha256 673dbc69fdc3f5a86fb5759ab19899039a8e5e6c631749e48dcd9c6f0c83541e        libpcap-1.8.1.tar.gz
+sha256 2edb88808e5913fdaa8e9c1fcaf272e19b2485338742b5074b9fe44d68f37019        libpcap-1.9.0.tar.gz
 
 # Hash for license file:
 sha256 8a54594d257e14a5260ac770f1633516cb51e3fc28c40136ce2697014eda7afd        LICENSE
index 8cc444e7af330774b75cf5e438ef704aa70f9af6..126087220b02aa0f56731af4cac422020b85c9f6 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBPCAP_VERSION = 1.8.1
+LIBPCAP_VERSION = 1.9.0
 LIBPCAP_SITE = http://www.tcpdump.org/release
 LIBPCAP_LICENSE = BSD-3-Clause
 LIBPCAP_LICENSE_FILES = LICENSE
@@ -15,7 +15,7 @@ LIBPCAP_CONF_ENV = \
        ac_cv_header_linux_wireless_h=yes \
        CFLAGS="$(LIBPCAP_CFLAGS)"
 LIBPCAP_CFLAGS = $(TARGET_CFLAGS)
-LIBPCAP_CONF_OPTS = --disable-yydebug --with-pcap=linux
+LIBPCAP_CONF_OPTS = --disable-yydebug --with-pcap=linux --without-dag
 LIBPCAP_CONFIG_SCRIPTS = pcap-config
 
 # Omit -rpath from pcap-config output