package/libgtk2: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:25 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:03 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libgtk2/libgtk2.mk

index 710e6e47db2cb78987fbe8cf067a71c0d9bb5060..9b7d39a532d2fb161b63cfeb500d85888a4b31ee 100644 (file)
@@ -35,6 +35,13 @@ LIBGTK2_CONF_OPTS += \
 LIBGTK2_DEPENDENCIES += \
        fontconfig xlib_libX11 xlib_libXext xlib_libXrender
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBGTK2_CONF_OPTS += --enable-introspection
+LIBGTK2_DEPENDENCIES += gobject-introspection
+else
+LIBGTK2_CONF_OPTS += --disable-introspection
+endif
+
 ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA),y)
 LIBGTK2_CONF_OPTS += --enable-xinerama
 LIBGTK2_DEPENDENCIES += xlib_libXinerama