package infra: fix versioned patches for host packages
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 6 Dec 2010 19:40:11 +0000 (16:40 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 27 Dec 2010 21:00:59 +0000 (22:00 +0100)
Without this patch we'd need separate versioned patch directories for
target and host packages, thus having unwanted duplication.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.package.in

index c4a1cf8ee1563b21df2fed12cabe46310a9eb03c..92ce4e22f821c311f2e2617434267546a0985651 100644 (file)
@@ -267,7 +267,7 @@ $(BUILD_DIR)/%/.stamp_patched:
            toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME) $(NAMEVER)\*.patch $(NAMEVER)\*.patch.$(ARCH) || exit 1; \
          else \
            toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME) $($(NOHOSTPKG)_NAME)\*.patch $($(NOHOSTPKG)_NAME)\*.patch.$(ARCH) || exit 1; \
-           if test -d $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME)/$(NAMEVER); then \
+           if test -d $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME)/$(NAMEVER); then \
              toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME)/$(NAMEVER) \*.patch \*.patch.$(ARCH) || exit 1; \
            fi; \
          fi; \