Support libiconv option for popt
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 25 Jan 2009 20:50:59 +0000 (20:50 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 25 Jan 2009 20:50:59 +0000 (20:50 -0000)
package/popt/popt.mk

index b2f7c8b4a22a29a84c74af40bc3c78cf9d7fc204..3c0ab0b5ab5a5e4f21863b219f0930acbd04d035 100644 (file)
@@ -5,9 +5,15 @@
 #############################################################
 POPT_VERSION:=1.14
 POPT_SITE:=http://rpm5.org/files/popt
-POPT_INSTALL_STAGING:=YES
-POPT_INSTALL_TARGET:=YES
-POPT_CONF_ENV:=ac_cv_va_copy=yes
+POPT_INSTALL_STAGING = YES
+POPT_INSTALL_TARGET = YES
+
+POPT_CONF_ENV = ac_cv_va_copy=yes
+
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+POPT_CONF_ENV += am_cv_lib_iconv=yes
+POPT_CONF_OPT += --with-libiconv-prefix=$(STAGING_DIR)/usr
+endif
 
 POPT_DEPENDENCIES:=uclibc