package/x11r7/xlib_libXfont: work around gcc bug 85180
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Mon, 15 Jul 2019 08:48:49 +0000 (10:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 18 Jul 2019 20:58:06 +0000 (22:58 +0200)
With Microblaze Gcc version < 8.x the build hangs due to gcc bug
85180: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85180. The bug
shows up when building xlib_libXfont with optimization but not when
building with -O0. To work around this, if
BR2_TOOLCHAIN_HAS_GCC_BUG_85180=y we force using -O0.

Fixes:
http://autobuild.buildroot.net/results/7c6/7c64becbf06a1e00e41b7ddb95dd0c65bf364eb7/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/x11r7/xlib_libXfont/xlib_libXfont.mk

index a1acfba83b7c479df75c03e6a84d2e24db7906a8..eeddfeebc9df5c394274edb96f60c720265d0acd 100644 (file)
@@ -30,5 +30,13 @@ ifeq ($(BR2_microblaze),y)
 XLIB_LIBXFONT_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -D__ELF__"
 endif
 
+XLIB_LIBXFONT_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
+XLIB_LIBXFONT_CFLAGS += -O0
+endif
+
+XLIB_LIBXFONT_CONF_ENV += CFLAGS="$(XLIB_LIBXFONT_CFLAGS)"
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))