New package: attr
authorYegor Yefremov <yegor_sub1@visionsystems.de>
Wed, 13 Jul 2011 09:12:29 +0000 (11:12 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jul 2011 13:02:38 +0000 (15:02 +0200)
Commands for Manipulating Filesystem Extended Attributes.

[Peter: needs largefile]
Signed-off-by: Heiko Zuerker <smiley73@users.sourceforge.net>
Signed-off-by: Daniel Mack <zonque@gmail.com>
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/attr/Config.in [new file with mode: 0644]
package/attr/attr.mk [new file with mode: 0644]

index d073a1b67d5a3555fd30323cb0087cfc2da8ae9f..069d8bb0b12588b5358e14e07579dc3248d65adf 100644 (file)
@@ -495,6 +495,7 @@ source "package/xmlstarlet/Config.in"
 endmenu
 
 menu "System tools"
+source "package/attr/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/bootutils/Config.in"
 endif
diff --git a/package/attr/Config.in b/package/attr/Config.in
new file mode 100644 (file)
index 0000000..79f2336
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_ATTR
+       bool "attr"
+       depends on BR2_LARGEFILE
+       help
+         Commands for Manipulating Filesystem Extended Attributes.
+         This package also provides libattr.
+
+         http://savannah.nongnu.org/projects/attr
+
+comment "attr requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/attr/attr.mk b/package/attr/attr.mk
new file mode 100644 (file)
index 0000000..b744ef6
--- /dev/null
@@ -0,0 +1,27 @@
+#############################################################
+#
+# attr
+#
+#############################################################
+
+ATTR_VERSION = 2.4.46
+ATTR_SOURCE = attr-$(ATTR_VERSION).src.tar.gz
+ATTR_SITE = http://download.savannah.gnu.org/releases/attr
+ATTR_INSTALL_STAGING = YES
+ATTR_CONF_OPT = --enable-gettext=no
+
+# While the configuration system uses autoconf, the Makefiles are
+# hand-written and do not use automake. Therefore, we have to hack
+# around their deficiencies by passing installation paths.
+ATTR_INSTALL_STAGING_OPT =                     \
+       prefix=$(STAGING_DIR)/usr               \
+       exec_prefix=$(STAGING_DIR)/usr          \
+       PKG_DEVLIB_DIR=$(STAGING_DIR)/usr/lib   \
+       install-dev install-lib
+
+ATTR_INSTALL_TARGET_OPT =                      \
+       prefix=$(TARGET_DIR)/usr                \
+       exec_prefix=$(TARGET_DIR)/usr           \
+       install install-lib
+
+$(eval $(call AUTOTARGETS,package,attr))