m4: remove deprecated target package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Jan 2015 14:30:22 +0000 (11:30 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 25 Jan 2015 23:21:49 +0000 (00:21 +0100)
It's been deprecated for a year now so remove the target variant.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/m4/Config.in [deleted file]
package/m4/m4.mk

index d6f32a0741fa1656c563ed5a2542b23379f08f5c..a8c5dabef2d1ac1f39424b6a7ebbaa1582ff024f 100644 (file)
@@ -102,6 +102,13 @@ endif
 
 comment "Legacy options removed in 2015.02"
 
+config BR2_PACKAGE_M4
+       bool "m4 target package removed"
+       select BR2_LEGACY
+       help
+         The m4 target package has been removed, it's been
+         deprecated for some time now.
+
 config BR2_PACKAGE_FLEX_BINARY
        bool "flex binary in target option removed"
        select BR2_LEGACY
index 2dc0ac654b0ab13d6bdb252d3f68ca9e39f5e82d..127ced341f4e68c2ea8326dec2eacb42a10533c5 100644 (file)
@@ -123,7 +123,6 @@ endif
        source "package/intltool/Config.in"
        source "package/jq/Config.in"
        source "package/libtool/Config.in"
-       source "package/m4/Config.in"
        source "package/make/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        source "package/patch/Config.in"
diff --git a/package/m4/Config.in b/package/m4/Config.in
deleted file mode 100644 (file)
index e2ce5b3..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-config BR2_PACKAGE_M4
-       bool "m4"
-       depends on BR2_USE_WCHAR
-       # uses fork()
-       depends on BR2_USE_MMU
-       # development tool, useless on the target
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       help
-         An implementation of the traditional Unix macro processor.
-
-         http://www.gnu.org/software/m4/m4.html
-
-comment "m4 needs a toolchain w/ wchar"
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       depends on BR2_USE_MMU
-       depends on !BR2_USE_WCHAR
index 32dfef492368020e2833f1f6a1a1f46c968e56f4..9b5d2d1fa92f9583f4016858f4b690fe9d482022 100644 (file)
@@ -9,13 +9,6 @@ M4_SOURCE = m4-$(M4_VERSION).tar.xz
 M4_SITE = $(BR2_GNU_MIRROR)/m4
 M4_LICENSE = GPLv3+
 M4_LICENSE_FILES = COPYING
-M4_CONF_ENV = gl_cv_func_gettimeofday_clobber=no
-
-ifneq ($(BR2_USE_WCHAR),y)
-M4_CONF_ENV += gt_cv_c_wchar_t=no gl_cv_absolute_wchar_h=__fpending.h
-endif
-
 HOST_M4_CONF_OPTS = --disable-static
 
-$(eval $(autotools-package))
 $(eval $(host-autotools-package))