pkg-waf: add additional variables for each install step
authorRomain Naour <romain.naour@gmail.com>
Tue, 6 Dec 2016 19:49:06 +0000 (20:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 11 Dec 2016 14:26:02 +0000 (15:26 +0100)
Some waf packages may want to pass additional variables to waf script
in install step. Add the possibility to do so by defining the
following variables:

  <pkg>_INSTALL_STAGING_OPTS for the install to staging directory
  <pkg>_INSTALL_TARGET_OPTS for the install to target directory

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-waf.mk

index 908ac0354e704faa8a96741e856eb8924dccdeaf..a82f45ce4919fa8b94eea355d9dbef748d9563b9 100644 (file)
@@ -49,6 +49,9 @@ else
 $(2)_WAF = ./waf
 endif
 
+$(2)_INSTALL_STAGING_OPTS              ?=
+$(2)_INSTALL_TARGET_OPTS               ?=
+
 #
 # Configure step. Only define it if not already defined by the package
 # .mk file.
@@ -84,7 +87,8 @@ ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
        cd $$(@D) && \
        $$(TARGET_MAKE_ENV) $$(HOST_DIR)/usr/bin/python2 $$($(2)_WAF) \
-               install --destdir=$$(STAGING_DIR)
+               install --destdir=$$(STAGING_DIR) \
+               $$($(2)_INSTALL_STAGING_OPTS)
 endef
 endif
 
@@ -96,7 +100,8 @@ ifndef $(2)_INSTALL_TARGET_CMDS
 define $(2)_INSTALL_TARGET_CMDS
        cd $$(@D) && \
        $$(TARGET_MAKE_ENV) $$(HOST_DIR)/usr/bin/python2 $$($(2)_WAF) \
-               install --destdir=$$(TARGET_DIR)
+               install --destdir=$$(TARGET_DIR) \
+               $$($(2)_INSTALL_TARGET_OPTS)
 endef
 endif