yaml-cpp: disable tests
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 11 Jun 2018 04:51:44 +0000 (06:51 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 11 Jun 2018 19:35:51 +0000 (21:35 +0200)
fork is used in tests so build fails without MMU

Fixes:
- http://autobuild.buildroot.net/results/3cb7c4d93e466c6eef69aacd0e561a9fb569e69b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/yaml-cpp/yaml-cpp.mk

index d97c84a7cf32eec2896d733c42aa729893b31aef..97021ea421877ebed96d832de05d9dde9243d966 100644 (file)
@@ -11,6 +11,8 @@ YAML_CPP_LICENSE = MIT
 YAML_CPP_LICENSE_FILES = LICENSE
 
 # Disable testing and parse tools
-YAML_CPP_CONF_OPTS += -DYAML_CPP_BUILD_TOOLS=OFF
+YAML_CPP_CONF_OPTS += \
+       -DYAML_CPP_BUILD_TESTS=OFF \
+       -DYAML_CPP_BUILD_TOOLS=OFF
 
 $(eval $(cmake-package))