libglib2: don't try to use DTrace/GCov/SystemTap for host build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Dec 2012 09:25:07 +0000 (09:25 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 10 Dec 2012 09:22:28 +0000 (10:22 +0100)
We really only need the host build of libglib2 for a few helper
programs that are used for the target build of libglib2. Therefore,
trying to use bells and whistles like DTrace, GCov and SystemTap is
totally useless.

And it is actually harmful, since it is causing build failures on the
gcc110 PowerPC-based autobuilder that apparently has some
DTrace-feature installed. This commit therefore fixes:

  http://autobuild.buildroot.org/results/1c62d1ce10937bd21f5afcb73782b939d10c2038/build-end.log

Which has been polluting our autobuilder logs since several weeks now.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libglib2/libglib2.mk

index a32cab20a34978b837a911e1962178e6664a0196..44274315cbf2e7146b77714d6d5859d11a9a8821 100644 (file)
@@ -53,6 +53,9 @@ endif
 HOST_LIBGLIB2_CONF_OPT = \
                --disable-gtk-doc \
                --enable-debug=no \
+               --disable-dtrace \
+               --disable-systemtap \
+               --disable-gcov
 
 LIBGLIB2_DEPENDENCIES = host-pkgconf host-libglib2 libffi zlib $(if $(BR2_NEEDS_GETTEXT),gettext)