Revert "linux: check the configuration file exists"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:16:36 +0000 (19:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Mar 2014 18:16:36 +0000 (19:16 +0100)
This reverts commit b4cacbf5b15db06132b5f401d39b4c8d4e79158e. The
whole host-lzop optional dependency logic cannot work, since the
configuration file will only be known after the kernel sources are
extracted, if an internal kernel defconfig is used, which is quite
common.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index ec7dfc39ec6fd65d5202d675b0a28fe7f6bcbead..cf728aad05d9c80eb8874c82d7d90647d47964ee 100644 (file)
@@ -166,10 +166,6 @@ else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
 KERNEL_SOURCE_CONFIG = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE))
 endif
 
-ifeq ($(wildcard $(KERNEL_SOURCE_CONFIG)),)
-$(error Configuration file '$(KERNEL_SOURCE_CONFIG)' not found.)
-endif
-
 ifeq ($(call KCONFIG_GET_OPT,CONFIG_KERNEL_LZO,$(KERNEL_SOURCE_CONFIG)),y)
 LINUX_DEPENDENCIES += host-lzop
 endif