libqrencode: select libpng only when tools are selected
authorDanomi Manchego <danomimanchego123@gmail.com>
Fri, 8 Nov 2013 03:10:39 +0000 (22:10 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 10 Nov 2013 11:35:31 +0000 (12:35 +0100)
As stated on the libqrencode web site, PNG (or SDL) is only
needed for the test and utility programs; the library itself
has no dependencies.

While we are here, remove spaces in the ifeq clause, to match
the examples in the buildroot manual.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libqrencode/Config.in
package/libqrencode/libqrencode.mk

index e8fc1d420dc81d252cedba1ff9fe993f682b5e21..b86662621e40d87fd14b186767aea17423eac928 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_LIBQRENCODE
        bool "libqrencode"
-       select BR2_PACKAGE_LIBPNG
        help
          libqrencode is a C library for encoding data in a QR Code
          symbol, a kind of 2D symbology that can be scanned by handy
@@ -14,6 +13,7 @@ if BR2_PACKAGE_LIBQRENCODE
 
 config BR2_PACKAGE_LIBQRENCODE_TOOLS
        bool "libqrencode tools"
+       select BR2_PACKAGE_LIBPNG
        help
          Build command-line tools
 
index e1f236240b8ef891185a7b218bd78be9d2c31d6b..d445763604af9807e9d5a44b3bc35c2ab8ef4574 100644 (file)
@@ -7,15 +7,15 @@
 LIBQRENCODE_VERSION = 3.4.2
 LIBQRENCODE_SOURCE = qrencode-$(LIBQRENCODE_VERSION).tar.gz
 LIBQRENCODE_SITE = http://fukuchi.org/works/qrencode
-LIBQRENCODE_DEPENDENCIES = libpng
 LIBQRENCODE_INSTALL_STAGING = YES
 LIBQRENCODE_LICENSE = LGPLv2.1+
 LIBQRENCODE_LICENSE_FILES = COPYING
 
 ifeq ($(BR2_PACKAGE_LIBQRENCODE_TOOLS),y)
-        LIBQRENCODE_CONF_OPT += --with-tools=yes
+LIBQRENCODE_CONF_OPT += --with-tools=yes
+LIBQRENCODE_DEPENDENCIES += libpng
 else
-        LIBQRENCODE_CONF_OPT += --with-tools=no
+LIBQRENCODE_CONF_OPT += --with-tools=no
 endif
 
 $(eval $(autotools-package))