toolchain-external: fix installation of libthread_db
authorRichard Braun <rbraun@sceen.net>
Tue, 20 Nov 2012 06:17:23 +0000 (06:17 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Nov 2012 21:57:49 +0000 (13:57 -0800)
Whatever the gdbserver source, as long as it's installed on the target,
assume it requires libthread_db.

Signed-off-by: Richard Braun <rbraun@sceen.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/ext-tool.mk

index a6025dbdd9ac2e287d508f60e2ca71958c693e6f..8ce0a84727b0e6537c17198e32987c692dd46a30 100644 (file)
@@ -61,7 +61,7 @@ endif
 
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
 LIB_EXTERNAL_LIBS+=libpthread.so
-ifeq ($(BR2_PACKAGE_GDB_SERVER),y)
+ifneq ($(BR2_PACKAGE_GDB_SERVER)$(BR2_TOOLCHAIN_EXTERNAL_GDB_SERVER_COPY),)
 LIB_EXTERNAL_LIBS+=libthread_db.so
 endif # gdbserver
 endif # ! no threads