kodi-audioencoder-vorbis: use pkg-config
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 29 Jul 2015 21:26:56 +0000 (23:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Jul 2015 07:29:24 +0000 (09:29 +0200)
Instead of passing multiple CMake variable, simply depend on
pkg-config: it is used by the FindVorbis and FindOgg modules in
priority over the hand-defined variables.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi-audioencoder-vorbis/kodi-audioencoder-vorbis.mk

index a7e99d1672ce0aaf076e7da8f768ab1c56453f98..e895ae3a9a5aebf2e40efe779d8633c2babc1339 100644 (file)
@@ -8,10 +8,6 @@ KODI_AUDIOENCODER_VORBIS_VERSION = 15d619dae4411ecebadf2ec2996d611600ad0bee
 KODI_AUDIOENCODER_VORBIS_SITE = $(call github,xbmc,audioencoder.vorbis,$(KODI_AUDIOENCODER_VORBIS_VERSION))
 KODI_AUDIOENCODER_VORBIS_LICENSE = GPLv2+
 KODI_AUDIOENCODER_VORBIS_LICENSE_FILES = src/EncoderVorbis.cpp
-KODI_AUDIOENCODER_VORBIS_DEPENDENCIES = kodi libogg libvorbis
-KODI_AUDIOENCODER_VORBIS_CONF_OPTS += \
-       -DOGG_INCLUDE_DIRS=$(STAGING_DIR)/usr/include \
-       -DVORBIS_INCLUDE_DIRS=$(STAGING_DIR)/usr/include \
-       -DVORBISENC_INCLUDE_DIRS=$(STAGING_DIR)/usr/include
+KODI_AUDIOENCODER_VORBIS_DEPENDENCIES = kodi libogg libvorbis host-pkgconf
 
 $(eval $(cmake-package))