python-iniparse: new package
authorZoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Sat, 30 Jan 2016 22:46:09 +0000 (23:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 22:28:12 +0000 (23:28 +0100)
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-iniparse/Config.in [new file with mode: 0644]
package/python-iniparse/python-iniparse.hash [new file with mode: 0644]
package/python-iniparse/python-iniparse.mk [new file with mode: 0644]

index 23fd62c07a9453be9d0b7620c28b30b8851eb788..ba501997934afba2a6c68f8d8065608f5f9da6e3 100644 (file)
@@ -656,6 +656,7 @@ menu "External python modules"
        source "package/python-httplib2/Config.in"
        source "package/python-id3/Config.in"
        source "package/python-idna/Config.in"
+       source "package/python-iniparse/Config.in"
        source "package/python-ipaddr/Config.in"
        source "package/python-ipaddress/Config.in"
        source "package/python-ipy/Config.in"
diff --git a/package/python-iniparse/Config.in b/package/python-iniparse/Config.in
new file mode 100644 (file)
index 0000000..65c1064
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PYTHON_INIPARSE
+       bool "python-iniparse"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         iniparse is an INI parser for Python which is API compatible
+         with the standard library's ConfigParser, preserves
+         structure of INI files (order of sections & options,
+         indentation, comments, and blank lines are preserved when
+         data is updated), and is more convenient to use.
+
+         https://pypi.python.org/pypi/iniparse
diff --git a/package/python-iniparse/python-iniparse.hash b/package/python-iniparse/python-iniparse.hash
new file mode 100644 (file)
index 0000000..d7d8e93
--- /dev/null
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=5e573e9e9733d97623881ce9bbe5eca6, sha256 locally computed
+md5 5e573e9e9733d97623881ce9bbe5eca6 iniparse-0.4.tar.gz
+sha256 abc1ee12d2cfb2506109072d6c21e40b6c75a3fe90a9c924327d80bc0d99c054  iniparse-0.4.tar.gz
+
diff --git a/package/python-iniparse/python-iniparse.mk b/package/python-iniparse/python-iniparse.mk
new file mode 100644 (file)
index 0000000..b00e0c4
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-iniparse
+#
+################################################################################
+
+PYTHON_INIPARSE_VERSION = 0.4
+PYTHON_INIPARSE_SOURCE = iniparse-$(PYTHON_INIPARSE_VERSION).tar.gz
+PYTHON_INIPARSE_SITE = https://pypi.python.org/packages/source/i/iniparse
+PYTHON_INIPARSE_LICENSE = Python software foundation license v2, MIT
+PYTHON_INIPARSE_LICENSE_FILES = LICENSE-PSF LICENSE
+PYTHON_INIPARSE_SETUP_TYPE = distutils
+
+$(eval $(python-package))