dhcpcd: new package
authorJohn Stile <johns@msli.com>
Mon, 11 Mar 2013 01:23:14 +0000 (18:23 -0700)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 18 Jun 2013 06:45:47 +0000 (08:45 +0200)
Dhcpcd is an RFC2131 compliant DHCP client.

[Peter: needs ipv6, fix whitespace/file header]
Signed-off-by: John Stile <john@stilen.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/dhcpcd/Config.in [new file with mode: 0644]
package/dhcpcd/dhcpcd.mk [new file with mode: 0644]

index bcc3470b75651712da197ae6e885b8a8cf95ec91..5b066dc35be9a9f4ec8edca927cf919a45771341 100644 (file)
@@ -703,6 +703,7 @@ source "package/hplip/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/dhcp/Config.in"
 endif
+source "package/dhcpcd/Config.in"
 source "package/dhcpdump/Config.in"
 source "package/dnsmasq/Config.in"
 source "package/dropbear/Config.in"
diff --git a/package/dhcpcd/Config.in b/package/dhcpcd/Config.in
new file mode 100644 (file)
index 0000000..a06a973
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_DHCPCD
+       depends on BR2_INET_IPV6
+       bool "dhcpcd"
+       help
+         An RFC2131 compliant DHCP client
+
+         http://roy.marples.name/downloads/dhcpcd
+
+comment "dhcpcd requires a toolchain with IPV6 support"
+       depends on !BR2_INET_IPV6
diff --git a/package/dhcpcd/dhcpcd.mk b/package/dhcpcd/dhcpcd.mk
new file mode 100644 (file)
index 0000000..9d4a72b
--- /dev/null
@@ -0,0 +1,42 @@
+################################################################################
+#
+# dhcpcd
+#
+################################################################################
+
+DHCPCD_VERSION = 5.6.7
+DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.bz2
+DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd/
+DHCPCD_LICENSE = BSD-2c
+
+ifeq ($(BR2_USE_MMU),)
+       DHCPCD_CONFIG_OPT += --disable-fork
+endif
+
+define DHCPCD_CONFIGURE_CMDS
+       (cd $(@D); \
+       ./configure \
+               --target=$(BR2_GCC_TARGET_ARCH) \
+               --os=linux \
+               $(DHCPCD_CONFIG_OPT) )
+endef
+
+define DHCPCD_BUILD_CMDS
+       $(MAKE) \
+               $(TARGET_CONFIGURE_OPTS) \
+               -C $(@D) all
+endef
+
+define DHCPCD_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/dhcpcd \
+               $(TARGET_DIR)/usr/bin/dhcpcd
+       $(INSTALL) -D -m 0644 $(@D)/dhcpcd.conf \
+               $(TARGET_DIR)/etc/dhcpcd.conf
+       $(INSTALL) -D -m 0755 $(@D)/dhcpcd-run-hooks \
+               $(TARGET_DIR)/libexec/dhcpcd-run-hooks
+endef
+
+# NOTE: Even though this package has a configure script, it is not generated
+# using the autotools, so we have to use the generic package infrastructure.
+
+$(eval $(call generic-package))