gcc: fix Fortran support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Sep 2013 16:06:30 +0000 (18:06 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 15 Sep 2013 20:54:41 +0000 (22:54 +0200)
This commit fixes the Fortran support in the gcc package by making
sure that the runtime Fortran library is properly installed to the
target.

It also takes this opportunity to slightly reword the Config.in option
help text, to no longer mention gcc < 4.2 since they are no longer
supported in Buildroot, and to have a more meaningful explanation.

Finally, it fixes the gcc-final.mk code to use the correct
BR2_INSTALL_FORTRAN option rather than the non-existing
BR2_GCC_CROSS_FORTRAN option, to decide whether Fortran support should
be enabled or not in the cross-compiler.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gcc/Config.in.host
package/gcc/gcc-final/gcc-final.mk

index 7e6df2d9e6b56c3cb827f5c277564c35996ce563..b440ee2e093c37cca86390f2e2237bd2ef981dd5 100644 (file)
@@ -119,13 +119,13 @@ config BR2_INSTALL_OBJC
          Build/install Objective-C compiler and runtime?
 
 config BR2_INSTALL_FORTRAN
-       bool "Build/install Fortran compiler and runtime?"
+       bool "Enable Fortran support"
        depends on !BR2_avr32
        select BR2_PACKAGE_LIBMPFR
        help
-         Build/install Fortran compiler and runtime?
-         Note that it is highly recommended NOT to use gfortran
-         from gcc older than 4.2.0
+         Enable the support for the Fortran language in the
+         cross-compiler, and install the Fortran runtime to the
+         target.
 
 config BR2_GCC_ENABLE_TLS
        bool "Enable compiler tls support" if BR2_TOOLCHAIN_BUILDROOT_UCLIBC
index 328ad7b0a68947a1abc17121186792d1ad2a4ddc..92b6f7ff7e82e8bae5ba736b6777b4e2560d6ed0 100644 (file)
@@ -34,7 +34,7 @@ HOST_GCC_FINAL_PRE_CONFIGURE_HOOKS += HOST_GCC_FINAL_CONFIGURE_SYMLINK
 # Languages supported by the cross-compiler
 GCC_FINAL_CROSS_LANGUAGES-y = c
 GCC_FINAL_CROSS_LANGUAGES-$(BR2_INSTALL_LIBSTDCPP) += c++
-GCC_FINAL_CROSS_LANGUAGES-$(BR2_GCC_CROSS_FORTRAN) += fortran
+GCC_FINAL_CROSS_LANGUAGES-$(BR2_INSTALL_FORTRAN) += fortran
 GCC_FINAL_CROSS_LANGUAGES-$(BR2_GCC_CROSS_OBJC)    += objc
 GCC_FINAL_CROSS_LANGUAGES = $(subst $(space),$(comma),$(GCC_FINAL_CROSS_LANGUAGES-y))
 
@@ -116,6 +116,10 @@ ifeq ($(BR2_GCC_ENABLE_OPENMP),y)
 HOST_GCC_FINAL_USR_LIBS += libgomp
 endif
 
+ifeq ($(BR2_INSTALL_FORTRAN),y)
+HOST_GCC_FINAL_USR_LIBS += libgfortran
+endif
+
 ifneq ($(HOST_GCC_FINAL_USR_LIBS),)
 define HOST_GCC_FINAL_INSTALL_USR_LIBS
        mkdir -p $(TARGET_DIR)/usr/lib