confusing busybox config option description patch, busybox can be built as shared...
authorJohn Voltz <john.voltz@gmail.com>
Fri, 21 Mar 2008 17:56:00 +0000 (17:56 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Fri, 21 Mar 2008 17:56:00 +0000 (17:56 -0000)
package/busybox/Config.in
package/busybox/busybox.mk

index daf33d265c088fb59a45966280c944eda38a1a7f..5ea1c277c8c858966a734f2979455e86f9cf0e3a 100644 (file)
@@ -49,13 +49,13 @@ config BR2_BUSYBOX_VERSION
        default "1.9.2"         if BR2_BUSYBOX_VERSION_1_9_X
 
 
-config BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS
-       bool "Install symlinks for BusyBox applets"
+config BR2_PACKAGE_BUSYBOX_FULLINSTALL
+       bool "Run BusyBox's own full installation"
        depends BR2_PACKAGE_BUSYBOX
        default y
        help
-         If you want to automatically install symlinks for all the
-         supported applets to the busybox binary, then answer Y.
+         If you want to run BusyBox's own full install for the
+         configured applets, then answer Y.
 
          This may overwrite files from other packages if your
          busybox includes replacement applets for the package.
index 80e26b59005b11a1440c43ea22b0cd545c91763a..c616e451decefd40347b47e72e9b6a5392ce6e18 100644 (file)
@@ -112,7 +112,7 @@ ifeq ($(BR2_PREFER_IMA)$(BR2_PACKAGE_BUSYBOX_SNAPSHOT),yy)
 endif
 
 $(TARGET_DIR)/bin/busybox: $(BUSYBOX_DIR)/busybox
-ifeq ($(BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS),y)
+ifeq ($(BR2_PACKAGE_BUSYBOX_FULLINSTALL),y)
        $(MAKE) CC=$(TARGET_CC) CROSS_COMPILE="$(TARGET_CROSS)" \
                CROSS="$(TARGET_CROSS)" PREFIX="$(TARGET_DIR)" \
                ARCH=$(KERNEL_ARCH) \