target-finalize: do not strip libthread_db
authorJavier Viguera <javier.viguera@digi.com>
Fri, 26 Nov 2010 18:26:56 +0000 (19:26 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 27 Nov 2010 20:41:20 +0000 (21:41 +0100)
Fix previous commit not to strip libthread_db library. In the previous
commit the wildcard was incorrectly matching the symbolic link instead
of the real library file.

Signed-off-by: Javier Viguera <javier.viguera@digi.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 6752aa65bfacf423588fe848c77d3de7e4cb5c9b..fc165e1b51b555dea4363e363ca0b970d74eef69 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -418,7 +418,7 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
        rm -rf $(TARGET_DIR)/usr/share/gtk-doc
        -rmdir $(TARGET_DIR)/usr/share 2>/dev/null
 endif
-       find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db.so*' | \
+       find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so' | \
                xargs $(STRIPCMD) 2>/dev/null || true
        find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
                xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED)