package/refpolicy: set python path
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 20 Apr 2019 14:55:33 +0000 (16:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 21 Apr 2019 09:46:40 +0000 (11:46 +0200)
Set python path to $(HOST_DIR)/usr/bin/python to avoid build failures if
python3 found on host is broken

Fixes:
 - http://autobuild.buildroot.org/results/1f878405593dd05bb00fe0b06ca1c64ffbe6c572

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/refpolicy/refpolicy.mk

index 78c17bad0133937eb1c290e5cfb1e5804801c5a8..1c3b1bc5419cb2a38d9f8a5ade66beccebd7113d 100644 (file)
@@ -26,6 +26,7 @@ endif
 
 # Cannot use multiple threads to build the reference policy
 REFPOLICY_MAKE = \
+       PYTHON=$(HOST_DIR)/usr/bin/python \
        TEST_TOOLCHAIN=$(HOST_DIR) \
        $(TARGET_MAKE_ENV) \
        $(MAKE1)