package/wireshark: add libssh optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 31 Oct 2018 22:56:46 +0000 (23:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 2 Nov 2018 20:43:18 +0000 (21:43 +0100)
- Optional dependency to libssh has been added with version 2.2.1 and
  https://github.com/wireshark/wireshark/commit/d6da95231ee790fd884ca2a41fe59aa9b05ccde9
- Specify the path to found libssh as this is done for other options

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wireshark/wireshark.mk

index fb90f2b940fc27434c54d73f21cab2c44de9fd08..4569a86cb1ccb89f2b89cf26dd0e8e475c240c0b 100644 (file)
@@ -92,6 +92,13 @@ else
 WIRESHARK_CONF_OPTS += --without-libnl
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSSH),y)
+WIRESHARK_CONF_OPTS += --with-libssh=$(STAGING_DIR)/usr
+WIRESHARK_DEPENDENCIES += libssh
+else
+WIRESHARK_CONF_OPTS += --without-libssh
+endif
+
 ifeq ($(BR2_PACKAGE_SBC),y)
 WIRESHARK_CONF_OPTS += --with-sbc=yes
 WIRESHARK_DEPENDENCIES += sbc