git: bump to version 1.8.5.2
authorAxel Lin <axel.lin@ingics.com>
Wed, 18 Dec 2013 06:14:40 +0000 (14:14 +0800)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 18 Dec 2013 11:07:21 +0000 (12:07 +0100)
Fixes since v1.8.5.1:
 * "git diff -- ':(icase)makefile'" was unnecessarily rejected at the
   command line parser.

 * "git cat-file --batch-check=ok" did not check the existence of
   the named object.

 * "git am --abort" sometimes complained about not being able to write
   a tree with an 0{40} object in it.

 * Two processes creating loose objects at the same time could have
   failed unnecessarily when the name of their new objects started
   with the same byte value, due to a race condition.

Also contains typofixes, documentation updates and trivial code clean-ups.

Signed-off-by: Axel Lin <axel.lin@ingics.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/git/git.mk

index cf162505b924838d5329def4fad48ec5b18b1d7f..3e198a6d99fbc53f3693501c6edcff42670e5e3f 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GIT_VERSION         = 1.8.5.1
+GIT_VERSION         = 1.8.5.2
 GIT_SITE            = http://git-core.googlecode.com/files/
 GIT_LICENSE         = GPLv2 LGPLv2.1+
 GIT_LICENSE_FILES   = COPYING LGPL-2.1