package/qpdf: fix 'no such file' exeption
authorAlexey Lukyanchuk <skif@skif-web.ru>
Fri, 1 May 2020 15:51:39 +0000 (18:51 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 1 May 2020 19:33:04 +0000 (21:33 +0200)
Without a source for randomness, qpdf will crash with 'no such file'
error. It's can me tested by command like 'qpd some_pdf.pdf -'.
This problem breaks cups printing.

This patch change configure options to '--with-random=/dev/urandom'

Signed-off-by: Alexey Lukyanchuk <skif@skif-web.ru>
[yann.morin.1998@free.fr: reword commit log]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qpdf/qpdf.mk

index ac703d716e6fc2ccb92f2ce5376b8ead4065a3a7..fd31140b0cba9be134a504ddc22edc5920a9374c 100644 (file)
@@ -11,7 +11,7 @@ QPDF_LICENSE = Apache-2.0 or Artistic-2.0
 QPDF_LICENSE_FILES = LICENSE.txt Artistic-2.0
 QPDF_DEPENDENCIES = host-pkgconf zlib jpeg
 
-QPDF_CONF_OPTS = --without-random
+QPDF_CONF_OPTS = --with-random=/dev/urandom
 
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 QPDF_CONF_OPTS += --enable-crypto-gnutls