xconfig: Change titlebar to Buildroot Configuration
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Jul 2009 21:47:42 +0000 (23:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Jul 2009 14:07:04 +0000 (16:07 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/config/kconfig-to-buildroot2.patch
package/config/qconf.cc

index 8e7ce42ad07786c85bb5b78de45d835323787c39..5f5d8ee7f8d1724a890415098c95e60874c6dfff 100644 (file)
@@ -7,10 +7,11 @@
  gconf.c             |    4 -
  gconf.glade         |    2 
  mconf.c             |   39 +++++++++----------
+ qconf.cc            |    3 -
  util.c              |  105 +++++++++++++++++++++++++++++++++++++++++++++++++++-
  zconf.tab.c_shipped |    2 
  zconf.y             |    2 
- 11 files changed, 238 insertions(+), 101 deletions(-)
+ 12 files changed, 239 insertions(+), 103 deletions(-)
 
 Index: config/Makefile
 ===================================================================
@@ -726,6 +727,20 @@ Index: config/mconf.c
 +      return conf_write_autoconf();
  }
  
+Index: config/qconf.cc
+===================================================================
+--- config.orig/qconf.cc
++++ config/qconf.cc
+@@ -1277,8 +1277,7 @@
+       char title[256];
+       QDesktopWidget *d = configApp->desktop();
+-      snprintf(title, sizeof(title), _("Linux Kernel v%s Configuration"),
+-              getenv("KERNELVERSION"));
++      snprintf(title, sizeof(title), _("Buildroot Configuration"));
+       setCaption(title);
+       width = configSettings->readNumEntry("/window width", d->width() - 64);
 Index: config/util.c
 ===================================================================
 --- config.orig/util.c
index ce7d508c75200b1072bb40c96e72701f742a6ddc..3e539c1c7a11baa1513c9eb09d37af40c1642170 100644 (file)
@@ -1277,8 +1277,7 @@ ConfigMainWindow::ConfigMainWindow(void)
        char title[256];
 
        QDesktopWidget *d = configApp->desktop();
-       snprintf(title, sizeof(title), _("Linux Kernel v%s Configuration"),
-               getenv("KERNELVERSION"));
+       snprintf(title, sizeof(title), _("Buildroot Configuration"));
        setCaption(title);
 
        width = configSettings->readNumEntry("/window width", d->width() - 64);