fcgiwrap: disable -Werror in CFLAGS
authorThomas Claveirole <thomas.claveirole@green-communications.fr>
Mon, 19 Jun 2017 16:26:05 +0000 (18:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 Jun 2017 19:21:18 +0000 (21:21 +0200)
fcgiwrap's configure script appends -Werror to AM_CFLAGS, then use it
to build the package.  This is an issue when Buildroot supports a new
compiler version and this version makes some warnings appear.
Luckily, one can provide CFLAGS=-Wno-error to the configure script so
it appends -Wno-error to AM_CFLAGS.

Fixes:

  http://autobuild.buildroot.net/results/8e04bf5a85ecd7f120bc9dedeedc891def6c46c1/

Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/fcgiwrap/fcgiwrap.mk

index dd74c1ef72e6e3754924c37f5cb900ce2a0aa18c..62c4c1369dbae71ee530d17640b53097db012e31 100644 (file)
@@ -10,6 +10,7 @@ FCGIWRAP_DEPENDENCIES = host-pkgconf libfcgi
 FCGIWRAP_LICENSE = MIT
 FCGIWRAP_LICENSE_FILES = COPYING
 FCGIWRAP_AUTORECONF = YES
+FCGIWRAP_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -Wno-error"
 
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 FCGIWRAP_DEPENDENCIES += systemd