xtensa: sqlite requires special compiler option
authorChris Zankel <chris@zankel.net>
Tue, 22 Jan 2013 10:33:19 +0000 (10:33 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 29 Jan 2013 23:19:42 +0000 (00:19 +0100)
Some of the generated object files are too large for PC-relative addressing,
so use the -mtext-section-literals compiler flag to move symbols closer to
the code.

[Peter: fix commit message]
Signed-off-by: Chris Zankel <chris@zankel.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sqlite/sqlite.mk

index bf4b921244db7941539ea6aeb3575cbdb29914c2..8eb6b2f76c0ec10f4cbfc57ab300e50272e7a2ad 100644 (file)
@@ -33,6 +33,10 @@ ifeq ($(BR2_PACKAGE_SQLITE_SECURE_DELETE),y)
 SQLITE_CFLAGS += -DSQLITE_SECURE_DELETE
 endif
 
+ifeq ($(BR2_xtensa),y)
+SQLITE_CFLAGS += -mtext-section-literals
+endif
+
 SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) $(SQLITE_CFLAGS)"
 
 SQLITE_CONF_OPT = \