package/rsyslog: add imhttp support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 15 Mar 2021 07:44:22 +0000 (08:44 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Mar 2021 20:52:49 +0000 (21:52 +0100)
imhttp support is available since version 8.2010.0 and only depends on
civetweb:
https://github.com/rsyslog/rsyslog/commit/6102f6083cfa73fe4a91e3d34c4d1dc924465278

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rsyslog/rsyslog.mk

index d20a13dbdd8f96c325c9104dc481e4852bd23627..6da2a469a9252e9d33586d5485b65b1165328c9b 100644 (file)
@@ -30,11 +30,17 @@ RSYSLOG_CONF_OPTS += --disable-elasticsearch \
        --disable-omhttp \
        --disable-fmhttp \
        --disable-imdocker \
-       --disable-imhttp \
        --disable-impcap \
        --disable-omhttpfs \
        --disable-mmkubernetes
 
+ifeq ($(BR2_PACKAGE_CIVETWEB_LIB),y)
+RSYSLOG_DEPENDENCIES += civetweb
+RSYSLOG_CONF_OPTS += --enable-imhttp
+else
+RSYSLOG_CONF_OPTS += --disable-imhttp
+endif
+
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 RSYSLOG_DEPENDENCIES += gnutls
 RSYSLOG_CONF_OPTS += --enable-gnutls