binutils: Also install libopcodes in staging
authorPaul Cercueil <paul@crapouillou.net>
Tue, 5 Aug 2014 23:00:09 +0000 (01:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Jan 2015 16:24:38 +0000 (17:24 +0100)
This library will be used later in the "lightning" package.

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/binutils/binutils.mk

index 1ff7fbafa59f91a99301e1828541bfcdbd85cb39..c3b3c18afd6d9d52191730d9b623c72db70f1492 100644 (file)
@@ -78,9 +78,11 @@ HOST_BINUTILS_CONF_OPTS = \
        $(BINUTILS_DISABLE_GDB_CONF_OPTS) \
        $(BINUTILS_EXTRA_CONFIG_OPTIONS)
 
-# We just want libbfd and libiberty, not the full-blown binutils in staging
+# We just want libbfd, libiberty and libopcodes,
+# not the full-blown binutils in staging
 define BINUTILS_INSTALL_STAGING_CMDS
        $(MAKE) -C $(@D)/bfd DESTDIR=$(STAGING_DIR) install
+       $(MAKE) -C $(@D)/opcodes DESTDIR=$(STAGING_DIR) install
        $(MAKE) -C $(@D)/libiberty DESTDIR=$(STAGING_DIR) install
 endef