gst-plugins-good: Allow souphttpsrc plugin to be configured.
authorWill Newton <will.newton@gmail.com>
Tue, 16 Jun 2009 20:40:43 +0000 (21:40 +0100)
committerWill Newton <will.newton@gmail.com>
Tue, 16 Jun 2009 20:42:07 +0000 (21:42 +0100)
Add a config option to enable the user to enable or disable the souphttpsrc
plugin.

Closes #383.

Signed-off-by: Will Newton <will.newton@gmail.com>
package/multimedia/gst-plugins-good/Config.in
package/multimedia/gst-plugins-good/gst-plugins-good.mk

index 5c5696cb238d4d1c9c4a810b69ab74b37e3ff085..b96f15d97c6e4bd0f8307abc758f3be916804473 100644 (file)
@@ -156,4 +156,8 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLAC
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS
        bool "ossaudio (OSS audio)"
 
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC
+       bool "souphttpsrc (http client)"
+       select BR2_PACKAGE_LIBSOUP
+
 endif
index 68acdeebd4e963cdc996fb99f258d3a7eb8ec601..75d25c88d73029bd78ecafef0c2da8524c087bdb 100644 (file)
@@ -286,4 +286,11 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-oss
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-soup
+GST_PLUGINS_GOOD_DEPENDENCIES += libsoup
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-soup
+endif
+
 $(eval $(call AUTOTARGETS,package/multimedia,gst-plugins-good))