openal: Add jack2 dependency
authorAndré Hentschel <nerv@dawncrow.de>
Sun, 13 Dec 2015 22:23:15 +0000 (23:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 13 Dec 2015 22:30:17 +0000 (23:30 +0100)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openal/openal.mk

index 0580526481852b04190644771fb065f1280af663..b2e02c895ebcef3fce04f918eadc1b1d5553ff23 100644 (file)
@@ -18,6 +18,13 @@ else
 OPENAL_CONF_OPTS += -DALSOFT_REQUIRE_ALSA=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_JACK2),y)
+OPENAL_DEPENDENCIES += jack2
+OPENAL_CONF_OPTS += -DALSOFT_REQUIRE_JACK=ON
+else
+OPENAL_CONF_OPTS += -DALSOFT_REQUIRE_JACK=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_PORTAUDIO),y)
 OPENAL_DEPENDENCIES += portaudio
 OPENAL_CONF_OPTS += -DALSOFT_REQUIRE_PORTAUDIO=ON