ipset: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 21 Jul 2011 19:49:57 +0000 (16:49 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 22 Jul 2011 07:07:58 +0000 (09:07 +0200)
Add ipset support package.
Note that this requires bleeding edge (>=2.6.39) kernel version or
patches.

[Peter: needs largefile, host-pkg-config]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/ipset/Config.in [new file with mode: 0644]
package/ipset/ipset.mk [new file with mode: 0644]

index 981a633dcec493b229aeee362c7093f4b08865a6..b9bd529924b5747f48166bb9200d9f6e0309ee5d 100644 (file)
@@ -407,6 +407,7 @@ source "package/ifplugd/Config.in"
 source "package/iperf/Config.in"
 source "package/iproute2/Config.in"
 source "package/ipsec-tools/Config.in"
+source "package/ipset/Config.in"
 source "package/iptables/Config.in"
 source "package/iw/Config.in"
 source "package/kismet/Config.in"
diff --git a/package/ipset/Config.in b/package/ipset/Config.in
new file mode 100644 (file)
index 0000000..af16fa8
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_IPSET
+       bool "ipset"
+       depends on BR2_LARGEFILE
+       select BR2_PACKAGE_LIBMNL
+       help
+         Utility to manage IP sets in the linux kernel.
+         Requires a patched kernel or version >=2.6.39.
+
+         http://ipset.netfilter.org/
+
+comment "ipset requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/ipset/ipset.mk b/package/ipset/ipset.mk
new file mode 100644 (file)
index 0000000..9d901fc
--- /dev/null
@@ -0,0 +1,13 @@
+#############################################################
+#
+# ipset
+#
+#############################################################
+
+IPSET_VERSION = 6.8
+IPSET_SOURCE = ipset-$(IPSET_VERSION).tar.bz2
+IPSET_SITE = http://ipset.netfilter.org
+IPSET_AUTORECONF = YES
+IPSET_DEPENDENCIES = libmnl host-pkg-config
+
+$(eval $(call AUTOTARGETS,package,ipset))