iucode-tool: argp-standalone also needed with musl
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 22 Jan 2016 09:06:05 +0000 (10:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 22 Jan 2016 09:08:29 +0000 (10:08 +0100)
The iucode-tool package needs the argp functionality, which is
provided built-in by glibc, but not by uClibc and musl. In uClibc
configurations, it correctly selects the argp-standalone package to
compensate this, but forgets to do so in musl-based
configurations. This commit fixes that by selecting the
argp-standalone package, and adjusting the dependency in the .mk file.

Fixes:

  http://autobuild.buildroot.net/results/7f8626db69500a84a393053a485f04180c565673/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/iucode-tool/Config.in
package/iucode-tool/iucode-tool.mk

index b996b36d35606b17d673c69989955930f8bc0e6f..aeb3b6e31647caae54d065d241953115301dbcd4 100644 (file)
@@ -2,7 +2,8 @@ config BR2_PACKAGE_IUCODE_TOOL
        bool "iucode-tool"
        depends on BR2_x86_64 || BR2_i386
        select BR2_PACKAGE_INTEL_MICROCODE
-       select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+       select BR2_PACKAGE_ARGP_STANDALONE \
+              if BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_MUSL
        help
          Intel processor microcode tool
 
index 44d49d9e9863a12c01b1fa207ce09688d7481428..30515f0f822236fb3d74d38db5245911c3b22b18 100644 (file)
@@ -6,7 +6,7 @@
 
 IUCODE_TOOL_VERSION = 1cbd73013cd4c6b2b287f07f6189eef35cb83ca0
 IUCODE_TOOL_SITE = git://gitorious.org/iucode-tool/iucode-tool.git
-ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
 IUCODE_TOOL_CONF_ENV = LIBS="-largp"
 IUCODE_TOOL_DEPENDENCIES = argp-standalone
 endif