yasm: New package
authorStefan Froberg <stefan.froberg@petroprogram.com>
Fri, 10 Aug 2012 19:30:11 +0000 (22:30 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Aug 2012 20:27:03 +0000 (22:27 +0200)
[thomas.petazzoni@free-electrons.com:

 drop the --disable-static from configuration options, the default
 behavior should work without problem.

 make sure the pre configure hook is also executed for the host
 variant of the package.

 add the project upstream URL in the package help text
]

Signed-off-by: Stefan Froberg <stefan.froberg@petroprogram.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/yasm/Config.in [new file with mode: 0644]
package/yasm/yasm.mk [new file with mode: 0644]

index 89cb40f5e99b7304cee446674c929bc7cb192c54..45f07995355b3428e06cdc5e6480954c066f7b61 100644 (file)
@@ -91,6 +91,7 @@ source "package/sstrip/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/tar/Config.in"
 endif
+source "package/yasm/Config.in"
 endmenu
 
 menu "Games"
diff --git a/package/yasm/Config.in b/package/yasm/Config.in
new file mode 100644 (file)
index 0000000..bb1d417
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_YASM
+       bool "yasm"
+       depends on BR2_i386 || BR2_x86_64
+       help
+         Yasm is a complete rewrite of the NASM-2.10.01 assembler.
+         It supports the x86 and AMD64 instruction sets, accepts NASM
+         and GAS assembler syntaxes and outputs binary, ELF32 and ELF64
+         object formats.
+
diff --git a/package/yasm/yasm.mk b/package/yasm/yasm.mk
new file mode 100644 (file)
index 0000000..ac75d2b
--- /dev/null
@@ -0,0 +1,20 @@
+#############################################################
+#
+# yasm
+#
+#############################################################
+YASM_VERSION = 1.2.0
+YASM_SOURCE = yasm-$(YASM_VERSION).tar.gz
+YASM_SITE = http://www.tortall.net/projects/yasm/releases/
+YASM_CONF_OPT = --disable-static
+
+define YASM_PRE_CONFIGURE_FIXUP
+# This sed prevents it compiling 2 programs (vsyasm and ytasm) 
+# that are only of use on Microsoft Windows. 
+       sed -i 's#) ytasm.*#)#' $(@D)/Makefile.in
+endef
+
+YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))