pkg-config: add usr/share/pkgconfig to search path as well
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 27 Mar 2011 19:20:04 +0000 (21:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 27 Mar 2011 19:20:04 +0000 (21:20 +0200)
A few packages (like xlib_xtrans) install their .pc files here, and
upstream pkg-config defaults to searching both /usr/lib/pkgconfig and
/usr/share/pkgconfig, so add it as well.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in
package/pkg-config/pkg-config.mk

index ef2c591cd6a927c4ccf576f9980f44ac29d042f2..e1ffe158b52c79375a9d7fd7e72c300ac23592b2 100644 (file)
@@ -241,7 +241,7 @@ HOST_CONFIGURE_OPTS=PATH=$(HOST_PATH) \
                PKG_CONFIG_ALLOW_SYSTEM_LIBS=1 \
                PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
                PKG_CONFIG_SYSROOT_DIR="/" \
-               PKG_CONFIG_LIBDIR="$(HOST_DIR)/usr/lib/pkgconfig" \
+               PKG_CONFIG_LIBDIR="$(HOST_DIR)/usr/lib/pkgconfig:$(HOST_DIR)/usr/share/pkgconfig" \
                PERLLIB="$(HOST_DIR)/usr/lib/perl" \
                LD_LIBRARY_PATH="$(HOST_DIR)/usr/lib:$(LD_LIBRARY_PATH)"
 
index bb52db87d2ae05840d0fa88f7512d1a085e15329..7189c91aa4453f2ea79b6656e56989b3a549b7e2 100644 (file)
@@ -12,7 +12,7 @@ PKG_CONFIG_DEPENDENCIES = libglib2
 PKG_CONFIG_CONF_OPT = --with-installed-glib
 
 HOST_PKG_CONFIG_CONF_OPT = \
-               --with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               --with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig:$(STAGING_DIR)/usr/share/pkgconfig" \
                --with-sysroot="$(STAGING_DIR)" \
                --disable-static