package/daemon: bump to version 0.7
authorBaruch Siach <baruch@tkos.co.il>
Sat, 21 Nov 2020 17:50:54 +0000 (19:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 7 Dec 2020 21:57:58 +0000 (22:57 +0100)
The configure script now runs 'make ready'. Drop it from BUILD_CMDS.

Refresh the musl support path.

Upstream now provides sha256 hashes. Format hashes with two spaces.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/daemon/0001-fix-musl.patch
package/daemon/daemon.hash
package/daemon/daemon.mk

index 9454d72ae6352c3e0c6e2223335c60338a189e0a..5ebb645973f02feb7c2f5e9079fc5ded7f1fb77e 100644 (file)
@@ -8,11 +8,11 @@ Signed-off-by: Baruch Siach <baruch@tkos.co.il>
 diff -Nuar daemon-0.6.4-orig/daemon.c daemon-0.6.4/daemon.c
 --- daemon-0.6.4-orig/daemon.c 2010-06-12 16:37:00.000000000 +0300
 +++ daemon-0.6.4/daemon.c      2017-05-01 22:02:17.721413468 +0300
-@@ -665,6 +665,7 @@
+@@ -864,6 +864,7 @@
  #ifdef _RESTORE_POSIX_SOURCE
  #define _POSIX_SOURCE
  #endif
 +#include <sys/ttydefaults.h>
+ #include <dirent.h>
  #include <sys/wait.h>
  #include <sys/stat.h>
- #include <sys/select.h>
index ad8637ee81f93714d03e5dc3499b0c1e2fe3d23f..b1c1dcdc2c5d800d4c9393c9b1ab7ce8930e1f33 100644 (file)
@@ -1,4 +1,3 @@
-# md5 from http://www.libslack.org/daemon/; sha256 locally calculated
-md5 6cd0a28630a29ac279bc501f39baec66 daemon-0.6.4.tar.gz
-sha256 c4b9ea4aa74d55ea618c34f1e02c080ddf368549037cb239ee60c83191035ca1 daemon-0.6.4.tar.gz
-sha256 204d8eff92f95aac4df6c8122bc1505f468f3a901e5a4cc08940e0ede1938994 LICENSE
+# From http://www.libslack.org/daemon/
+sha256  f66af2ece784c16dcb5219de1f4fa3ae5787bb3374e44bd4b1d3e275e8ff272c  daemon-0.7.tar.gz
+sha256  204d8eff92f95aac4df6c8122bc1505f468f3a901e5a4cc08940e0ede1938994  LICENSE
index 79cf3f7aab742d952ddab494561f72de7c958e14..f3a1917fadc145b6b58f44e67feb35c23437174c 100644 (file)
@@ -4,17 +4,16 @@
 #
 ################################################################################
 
-DAEMON_VERSION = 0.6.4
+DAEMON_VERSION = 0.7
 DAEMON_SITE = http://libslack.org/daemon/download
 DAEMON_LICENSE = GPL-2.0+
 DAEMON_LICENSE_FILES = LICENSE
 
 define DAEMON_CONFIGURE_CMDS
-       (cd $(@D); ./config)
+       (cd $(@D); ./configure)
 endef
 
 define DAEMON_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) ready
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
 endef