iostat: ensure binary gets installed with proper permissions
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 22:16:45 +0000 (23:16 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 22:16:45 +0000 (23:16 +0100)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/iostat/iostat.mk

index 2080e5653d60c8f2646136f545a674ea5a54d19e..d19a15af8e166a6f5dbd8958b939b32b3649eb80 100644 (file)
@@ -16,7 +16,7 @@ define IOSTAT_BUILD_CMDS
 endef
 
 define IOSTAT_INSTALL_TARGET_CMDS
-       $(INSTALL) -D $(IOSTAT_DIR)/iostat $(TARGET_DIR)/usr/bin/iostat
+       $(INSTALL) -D -m 0755 $(IOSTAT_DIR)/iostat $(TARGET_DIR)/usr/bin/iostat
 endef
 
 $(eval $(generic-package))