cleanup grep makefile
authorJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:11:51 +0000 (18:11 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Thu, 6 Mar 2008 18:11:51 +0000 (18:11 -0000)
package/grep/grep.mk

index ed019b211b2cac39bdb619ad3fbb37827554c1f6..c12b1df1c4740fd6fac8cb0c6d4e17daf6119345 100644 (file)
@@ -23,7 +23,7 @@ $(GNUGREP_DIR)/.unpacked: $(DL_DIR)/$(GNUGREP_SOURCE)
        $(GNUGREP_CAT) $(GNUGREP_DIR).xxx/grep_$(GNUGREP_VERSION).tar.gz | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        rm -rf $(GNUGREP_DIR).xxx
        $(CONFIG_UPDATE) $(GNUGREP_DIR)
-       touch $(GNUGREP_DIR)/.unpacked
+       touch $@
 
 $(GNUGREP_DIR)/.configured: $(GNUGREP_DIR)/.unpacked
        (cd $(GNUGREP_DIR); rm -rf config.cache; \
@@ -49,7 +49,7 @@ $(GNUGREP_DIR)/.configured: $(GNUGREP_DIR)/.unpacked
                --disable-perl-regexp \
                --without-included-regex \
        )
-       touch $(GNUGREP_DIR)/.configured
+       touch $@
 
 $(GNUGREP_DIR)/$(GNUGREP_BINARY): $(GNUGREP_DIR)/.configured
        $(MAKE) -C $(GNUGREP_DIR)