mtools: fix build when libiconv is enabled
authorBernd Kuhls <berndkuhls@hotmail.com>
Sat, 22 Mar 2014 13:47:40 +0000 (14:47 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 23 Mar 2014 20:22:06 +0000 (21:22 +0100)
Fixes
http://autobuild.buildroot.net/results/298/298858b6cc89438dcd044c74dff4231186a065e1/
http://autobuild.buildroot.net/results/7e7/7e7e7027226bb0251e32a90df2f00d9e84aedaaf/
http://autobuild.buildroot.net/results/c18/c18e7da16121417e597a153ce7dc2a3b64ece3b0/
http://autobuild.buildroot.net/results/b29/b29e80441ed87be651d720ae2dccf24d0f7fe8b6/

Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mtools/mtools.mk

index 4880245e250d39d52638f41cb83041519662e081..864932507e28a76dde7960f774c902d49591aa55 100644 (file)
@@ -12,5 +12,11 @@ MTOOLS_LICENSE_FILES = COPYING
 MTOOLS_CONF_ENV = ac_cv_func_setpgrp_void=yes
 MTOOLS_CONF_OPT = --without-x
 
+# link with iconv if enabled
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MTOOLS_DEPENDENCIES += libiconv
+MTOOLS_CONF_ENV += LIBS=-liconv
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))