libxslt: fix host compilation
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 28 Apr 2010 21:40:43 +0000 (23:40 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 21:25:15 +0000 (23:25 +0200)
Do not build against libgcrypt on the host, since we don't build
libgcrypt ourself, and it might fail even when libgcrypt is installed
on the host:

...configure...
checking for libgcrypt-config... /usr/bin/libgcrypt-config
Crypto extensions will be available.

...build...
gcc: /usr/lib/libgcrypt.so: No such file or directory

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/libxslt/libxslt.mk

diff --git a/CHANGES b/CHANGES
index 4ef1fc78153b70d7d0277db9956321a2cc3a4fd7..57d6de172c9acd49eda4172958f0e6ea01c70cec 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -15,7 +15,7 @@
        Updated/fixed packages: alsa-utils, busybox, dnsmasq,
        dosfstools, e2fsprogs, eeprog, fbv, freetype, haserl, hostapd,
        iperf, iptables, iw, less, libaio,libdrm, libgcrypt, libglib2,
-       libpng, libxml2, lua, matchbox, mdadm, memstat, mesa3d,
+       libpng, libxml2, libxslt, lua, matchbox, mdadm, memstat, mesa3d,
        mtd-utils, nano, openssl, pciutils, php, pixman, portage,
        pppd, pthread-stubs, python, qt, radvd, samba, setserial,
        squashfs, tslib, usb_modeswith, wget, xdata_xcursor-themes,
index 407924d4dc3eea054c34eeb9a13e117d6b533e89..e77663df203bfc01f04139fb1d6ccd5c8ed83f80 100644 (file)
@@ -27,7 +27,8 @@ LIBXSLT_DEPENDENCIES = libxml2 $(LIBXSLT_DEPENDENCIES_EXTRA)
 HOST_LIBXSLT_CONF_OPT = --enable-shared \
                        --without-debugging \
                        --without-python \
-                       --without-threads
+                       --without-threads \
+                       --without-crypto
 
 HOST_LIBXSLT_DEPENDENCIES = host-libxml2