Finish the gtk-doc stuff and start on the smae thing with LARGEFILE and NLS.
authorThomas Lundquist <lists@zelow.no>
Sun, 18 Jan 2009 00:05:57 +0000 (00:05 -0000)
committerThomas Lundquist <lists@zelow.no>
Sun, 18 Jan 2009 00:05:57 +0000 (00:05 -0000)
package/Makefile.autotools.in
package/libgtk2/libgtk2.mk
package/multimedia/gst-plugins-base/gst-plugins-base.mk
package/multimedia/gst-plugins-good/gst-plugins-good.mk
package/multimedia/gst-plugins-ugly/gst-plugins-ugly.mk
package/multimedia/gstreamer/gstreamer.mk

index 72e4c599c15b13e78c960466684d95cfbaaa3610..eacdec95bf0804c15f24c345e985798e86939438 100644 (file)
@@ -249,6 +249,8 @@ $(BUILD_DIR)/%/.stamp_configured:
                --exec-prefix=/usr \
                --sysconfdir=/etc \
                $(DISABLE_DOCUMENTATION) \
+               $(DISABLE_NLS) \
+               $(DISABLE_LARGEFILE) \
                $(QUIET) $($(PKG)_CONF_OPT)
        $(Q)touch $@
 
index 6532b542a706a4c05e20c7ae3742b470431cc345..57a0b90ac8718643ce99054475c9559fd245c0e1 100644 (file)
@@ -75,7 +75,6 @@ LIBGTK2_CONF_OPT = --enable-shared \
                --disable-glibtest \
                --enable-explicit-deps=no \
                --disable-debug \
-               --without-html-dir \
                $(DISABLE_LARGEFILE) \
                $(LIBGTK2_CONF_OPT_X)  \
                $(LIBGTK2_CONF_OPT_DFB)
index 2f7f926826bb734e307360cef052034af937baeb..21f2acaaa98d1cee3ebe9461a9913534713e53e0 100644 (file)
@@ -17,9 +17,7 @@ GST_PLUGINS_BASE_CONF_OPT = \
                --disable-xshm \
                --disable-oggtest \
                --disable-vorbistest \
-               --disable-freetypetest \
-               --disable-gtk-doc \
-               --without-html-dir
+               --disable-freetypetest
 
 GST_PLUGINS_BASE_DEPENDENCIES = gstreamer liboil
 
index 37f6e0abf76fbf7b7a0f3e5e3e33d925769b5fd3..bef8d01b0d6c80a0d81a95deb33f549c65b3ec50 100644 (file)
@@ -22,9 +22,7 @@ GST_PLUGINS_GOOD_CONF_OPT = \
                --disable-aalibtest \
                --disable-esdtest \
                --disable-shout2 \
-               --disable-shout2test \
-               --disable-gtk-doc \
-               --without-html-dir
+               --disable-shout2test
 
 GST_PLUGINS_GOOD_DEPENDENCIES = gstreamer gst-plugins-base
 
index c606ac6d6c01990715ad2754684ae45743ff7f44..f0cf4789e0aa241b9d27739031d3719fbd432af1 100644 (file)
@@ -9,9 +9,7 @@ GST_PLUGINS_UGLY_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-ugly
 
 GST_PLUGINS_UGLY_CONF_OPT = \
                $(DISABLE_NLS) \
-               --disable-examples \
-               --disable-gtk-doc \
-               --without-html-dir
+               --disable-examples
 
 GST_PLUGINS_UGLY_DEPENDENCIES = gstreamer gst-plugins-base
 
index 6b7a7512decb0756a1dcc28a5869c23a4e768e4f..3d4033e199fc75c30a7f373a46cc6b04bec196fc 100644 (file)
@@ -23,9 +23,7 @@ GSTREAMER_CONF_OPT = \
                $(DISABLE_LARGEFILE) \
                --disable-examples \
                --disable-tests \
-               --disable-failing-tests \
-               --disable-gtk-doc \
-               --without-html-dir
+               --disable-failing-tests
 
 GSTREAMER_DEPENDENCIES = libglib2 libxml2 pkgconfig